const regex = new RegExp('(?:(?:192\\.)(?:(?:168\\.)(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?\\.)(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)))|(?:(?:10\\.)(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){2}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|(?:(?:172\\.)(?:(?:1[6-9]|2[0-9]|3[0-1])\\.)(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.)(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))', 'gm')
const str = `10.10.1.1
172.16.11.5
172.31.255.255
172.30.12.11
172.19.12.22
10.1.12.3
10.0.0.0
192.168.1.1
192.168.12.3
11.156.11.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}