#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b\d{1,3}(?:,\d{2,3})*(?:,\d{3})*(?:\.\d+)?\b"
Local $sString = "problem satatement is to get all the amount despite of inconsistencies in comma or dollar sign also I need to exclude year from that (if no pattern can be made asssume to get all the amount greater than 3000)" & @CRLF & _
"" & @CRLF & _
"$ 1,000,000.6522 " & @CRLF & _
"$ 3,500,000 " & @CRLF & _
"90,00,00,000" & @CRLF & _
"5000000" & @CRLF & _
"200" & @CRLF & _
"200,000" & @CRLF & _
"20,00,000" & @CRLF & _
"" & @CRLF & _
"1,000" & @CRLF & _
"$ 4,000,000 for the 2023 " & @CRLF & _
"800,000" & @CRLF & _
"90.65" & @CRLF & _
"" & @CRLF & _
"5,555" & @CRLF & _
"5000" & @CRLF & _
"" & @CRLF & _
"2021 --------this should be excluded from the pattern" & @CRLF & _
"" & @CRLF & _
"89jfe90ABI900 ----this also should be excluded from the pattern"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")