import Foundation
let pattern = #"\b\d{1,3}(?:,\d{2,3})*(?:,\d{3})*(?:\.\d+)?\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
problem satatement is to get all the amount despite of inconsistencies in comma or dollar sign also I need to exclude year from that (if no pattern can be made asssume to get all the amount greater than 3000)
$ 1,000,000.6522
$ 3,500,000
90,00,00,000
5000000
200
200,000
20,00,000
1,000
$ 4,000,000 for the 2023
800,000
90.65
5,555
5000
2021 --------this should be excluded from the pattern
89jfe90ABI900 ----this also should be excluded from the pattern
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}