const regex = /(?<=(?:^|\s)[a-zA-Zа-яА-Я]+\s)#[a-zA-Zа-яА-Я]+(?=[,.!:?\s]*\s[a-zA-Zа-яА-Я])/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:^|\\s)[a-zA-Zа-яА-Я]+\\s)#[a-zA-Zа-яА-Я]+(?=[,.!:?\\s]*\\s[a-zA-Zа-яА-Я])', 'gu')
const str = `#Yandex #Apple Chainlink выпустил новую платформу для разработчиков #Functions, которая предоставляет бесплатный доступ к готовым функциям оракулов, упрощая процесс создания децентрализованных приложений на #Blockchain #Chainlink #девелопмент`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}