$re = '/(?<=(?:^|\s)[a-zA-Zа-яА-Я]+\s)#[a-zA-Zа-яА-Я]+(?=[,.!:?\s]*\s[a-zA-Zа-яА-Я])/u';
$str = '#Yandex #Apple Chainlink выпустил новую платформу для разработчиков #Functions, которая предоставляет бесплатный доступ к готовым функциям оракулов, упрощая процесс создания децентрализованных приложений на #Blockchain #Chainlink #девелопмент';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);