package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(CR)\s?(\d{3})\-?(\d{4})`)
var str = `CR 722-2018
CR7222018
-CR 7222018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}