$re = '/.*?(CR)\s?(\d{3})\-?(\d{4})/m';
$str = 'CR 722-2018
CR7222018
-CR 7222018';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);