$re = '/(\[.*\]\s)([A-Za-z0-9\s]+)/m';
$str = '[Section A]
55555
66666
77777
[Section B]
AAAAA
BBBBB
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);