re = /(\[.*\]\s)([A-Za-z0-9\s]+)/m
str = '[Section A]
55555
66666
77777
[Section B]
AAAAA
BBBBB
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end