$re = '/^[0-9]{9}(?:,[0-9]{9})*$/m';
$str = '123456789,123456789,123456789
123456789
123456789,123456789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);