re = /^[0-9]{9}(?:,[0-9]{9})*$/m
str = '123456789,123456789,123456789
123456789
123456789,123456789
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end