#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=[\*]|\d{6}).*"
Local $sString = "So ex: " & @CRLF & _
"*shdjlfl" & @CRLF & _
"Ajskdlldmdkdkls" & @CRLF & _
"345356 ajdjdk" & @CRLF & _
"72shskskn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")