$re = '/(?<=[\*]|\d{6}).*/mi';
$str = 'So ex:
*shdjlfl
Ajskdlldmdkdkls
345356 ajdjdk
72shskskn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);