#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^([A-Z0-9]+).*?(\d+\/\d+\/\d+).*?(\d+:\d+).*?Ksh(\d+(?:\.\d+)?).*?(\d+)\s([^.]+).*$"
Local $sString = "QAP04N99TG Confirmed.on 25/1/22 at 1:57 PMKsh1.00 received from 1123123322 JOHN DUE MARTIN. New Account balance is Ksh10.00. Transaction cost, Ksh0.00."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")