re = /^([A-Z0-9]+).*?(\d+\/\d+\/\d+).*?(\d+:\d+).*?Ksh(\d+(?:\.\d+)?).*?(\d+)\s([^.]+).*$/m
str = 'QAP04N99TG Confirmed.on 25/1/22 at 1:57 PMKsh1.00 received from 1123123322 JOHN DUE MARTIN. New Account balance is Ksh10.00. Transaction cost, Ksh0.00.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end