package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<bracket>\()?\d+(?(<bracket>)\))$`)
var str = `123
(1234)
1
(33)
(123
123)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}