$re = '/^(?<bracket>\()?\d+(?(<bracket>)\))$/m';
$str = '123
(1234)
1
(33)
(123
123)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);