import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\W\\n?(((1|2)[0-9]|3[0-1]|0?[1-9])\\/(0?[1-9]|1[0-2])\\/((19|20)?[0-9]{2})|((1|2)[0-9]|3[0-1]|0?[1-9])\\-(0?[1-9]|1[0-2])\\-((19|20)?[0-9]{2})|((19|20)?[0-9]{2})\\/((1|2)[0-9]|3[0-1]|0?[1-9])\\/(0?[1-9]|1[0-2])|((19|20)?[0-9]{2})\\-((1|2)[0-9]|3[0-1]|0?[1-9])\\-(0?[1-9]|1[0-2]))\\W\\n?";
final String string = " 12-01-2019\n"
+ " 01/10/2019\n"
+ " 1-12-1901\n"
+ " 04/04/2019\n"
+ " 2000-02-12\n"
+ " 2000/10/12\n"
+ " 1800-1-9\n"
+ " 1976/3/1\n"
+ " 32/01/3019\n"
+ " 9/1/30\n\n"
+ "5542-21-54\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}