#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([r])([1-9A-HJ-NP-Za-km-z]{24,34})$"
Local $sString = "// valid addresses" & @CRLF & _
"rf1BiGeXwwQoi8Z2ueFYTEXSwuJYfV2Jpn" & @CRLF & _
"r9kiSEUEw6iSCNksDVKf9k3AyxjW3r1qPf" & @CRLF & _
"rs2qdz5stxyWeMk6sNz5mLY6h5xxPYNJ8u" & @CRLF & _
"rfe8yiZUymRPx35BEwGjhfkaLmgNsTytxT" & @CRLF & _
"rPE9dw1gR8ravY2o25zudXmj2L28UTNt4D" & @CRLF & _
"r9vbV3EHvXWjSkeQ6CAcYVPGeq7TuiXY2X" & @CRLF & _
"" & @CRLF & _
"// invalid addresses (with O, I, l or 0)" & @CRLF & _
"rPE9dw1gR8ravY2o25zudXmj2L20UTNt4D" & @CRLF & _
"r9vbV3EHvXWjSkeQ6CAcYVPGel7TuiXY2X" & @CRLF & _
"r9vbV3EHvXWjSkeQ6CAcYVPGeqOTuiXY2X" & @CRLF & _
"r9vbV3EHvXWjSkeQ6CAcYVPGeqITuiXY2X" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")