import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([r])([1-9A-HJ-NP-Za-km-z]{24,34})$";
final String string = "// valid addresses\n"
+ "rf1BiGeXwwQoi8Z2ueFYTEXSwuJYfV2Jpn\n"
+ "r9kiSEUEw6iSCNksDVKf9k3AyxjW3r1qPf\n"
+ "rs2qdz5stxyWeMk6sNz5mLY6h5xxPYNJ8u\n"
+ "rfe8yiZUymRPx35BEwGjhfkaLmgNsTytxT\n"
+ "rPE9dw1gR8ravY2o25zudXmj2L28UTNt4D\n"
+ "r9vbV3EHvXWjSkeQ6CAcYVPGeq7TuiXY2X\n\n"
+ "// invalid addresses (with O, I, l or 0)\n"
+ "rPE9dw1gR8ravY2o25zudXmj2L20UTNt4D\n"
+ "r9vbV3EHvXWjSkeQ6CAcYVPGel7TuiXY2X\n"
+ "r9vbV3EHvXWjSkeQ6CAcYVPGeqOTuiXY2X\n"
+ "r9vbV3EHvXWjSkeQ6CAcYVPGeqITuiXY2X\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}