# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(c(?:\+{2}|#)|\.net\b)|[!,.:;\/—]|-(?=[\d.])/\1 /gmi;t' <<< "Must-have skills: -.Net programming experience; -2 years experience in C++; C#/.Net, C++/.Net, C./.Net.
"