import re
regex = re.compile(r"(c(?:\+{2}|#)|\.net\b)|[!,.:;/—]|-(?=[\d.])", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Must-have skills: -.Net programming experience; -2 years experience in C++; C#/.Net, C++/.Net, C./.Net.\n")
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)