$re = '/\d*\.a../m';
$str = '# Quantifier:* 篇
#下方為測試文字區塊
AE-403.jpg
BK-201.BMP
Qb-666.acg
AZ-404.qoo
ae-103.png
BK-201.svg
qb-666.ai
az-404.ai.tmp
qK-.ajpg
#解釋:藍色部分就是透過規則/\\d+\\.a../所配對成功的文字。
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);