import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(?:(?!\\/)).*(?:\\/)(.[A-Z0-9]*[-][0-9]*)";
        final String string = "\"Currently WV Patients are having difficulty reading some of the information on Key pages like product pages/shipping information etc. this story is to fix some of the font colors/size etc for better user experience.  UP9-9999\\n\\n\n\n"
	 + "[https://our-domain.atlassian.net/browse/UP-7930#icft=UP-7930|https://our-domain.atlassian.net/browse/UP-7930#icft=UP-7930] \\n\\n\n\n"
	 + "[https://our-domain.atlassian.net/browse/UP-6744#icft=UP-6744|https://our-domain.atlassian.net/browse/UP1-6744#icft=UP-6744]\\n\\n\n\n"
	 + " and\\n\\n\\\n"
	 + "[https://our-domain.atlassian.net/browse/UP-6396|https://emersonecologics.atlassian.net/browse/UP-6396] \\n\\n\n\n"
	 + "end more\\n\\n\n\n"
	 + "[https://our-domain.net/browse/UP-5746|https://emersonecologics.atlassian.net/browse/UP2-5746]\\n\\n\n\n"
	 + "test 2\",";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}