package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0*(\d?\d|100)$`)
var str = `0023
101
0
56
100
230
-23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}