$re = '/^0*(\d?\d|100)$/m';
$str = '0023
101
0
56
100
230
-23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);