# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$"
test_str = ("# Valid\n"
"victor.schroeder@35up.com\n"
"victor.schroeder+foo@35up.com\n"
"v_s@35up.com\n"
"1233@35up.com\n"
"victor.schroeder@xn--bcher-kva.de\n\n"
"# Invalid\n"
"victor.schroeder@35up\n"
"victor.schroeder@.35up.com\n"
"victor.schroeder@35up.com.\n"
"victor.schroeder@-35up.com\n"
"victor.schroeder@35up-.com\n"
"victor.schroeder@35up.com-\n"
"victor.schroeder@35up.-com\n"
"victor.schroeder.@35up.com\n"
"victor.schroeder@35up..com\n"
".victor.schroeder@35up.com\n"
"victor.schroeder@35--up.com\n"
"victor.schroeder@xn---bcher-kva.de\n"
"victor.schroeder@35_up.com\n\n"
"# Blacklisted chars\n"
"victor;schroeder@35up.com\n"
"victor,schroeder@35up.com\n"
"victor@schroeder@35up.com\n"
"victor[schroeder@35up.com\n"
"victor]schroeder@35up.com\n"
"victor(schroeder@35up.com\n"
"victor)schroeder@35up.com\n"
"victor<schroeder@35up.com\n"
"victor>schroeder@35up.com\n"
"victor:schroeder@35up.com\n"
"victor schroeder@35up.com\n"
"victor\\schroeder@35up.com\n"
"victor\"schroeder@35up.com")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.