using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http(?:s)?(.*(?=\.jpg))";
string input = @"https://superp/image.22-1u1.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}