$re = '/http(?:s)?(.*(?=\.jpg))/m';
$str = 'https://superp/image.22-1u1.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);