using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""]+""):\s*{[^}]*},?\K";
string substitution = @"\1";
string input = @"""g1"": {
""k1"": ""v1"",
""k2"": ""v2"",
""k3"": ""v3""
},
""g2"": {
""k4"": ""v4"",
""k5"": ""v5"",
""k6"": ""v6""
},
""g3"": {
""k7"": ""v7"",
""k8"": ""v8"",
""k9"": ""v9""
},
""g1"": {
""k1"": ""v1"",
""k2"": ""v2"",
""k3"": ""v3""
},
""g2"": {
""k4"": ""v4"",
""k5"": ""v5"",
""k6"": ""v6""
},
""g3"": {
""k7"": ""v7"",
""k8"": ""v8"",
""k9"": ""v9""
},
""g1"": {
""k1"": ""v1"",
""k2"": ""v2"",
""k3"": ""v3""
},
""g2"": {
""k4"": ""v4"",
""k5"": ""v5"",
""k6"": ""v6""
},
""g3"": {
""k7"": ""v7"",
""k8"": ""v8"",
""k9"": ""v9""
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}