import re
regex = re.compile(r"(\"[^\"]+\"):\s*{[^}]*},?\K")
test_str = ("\"g1\": {\n"
" \"k1\": \"v1\",\n"
" \"k2\": \"v2\",\n"
" \"k3\": \"v3\"\n"
"},\n"
"\"g2\": {\n"
" \"k4\": \"v4\",\n"
" \"k5\": \"v5\",\n"
" \"k6\": \"v6\"\n"
"},\n"
"\"g3\": {\n"
" \"k7\": \"v7\",\n"
" \"k8\": \"v8\",\n"
" \"k9\": \"v9\"\n"
"},\n"
"\"g1\": {\n"
" \"k1\": \"v1\",\n"
" \"k2\": \"v2\",\n"
" \"k3\": \"v3\"\n"
"},\n"
"\"g2\": {\n"
" \"k4\": \"v4\",\n"
" \"k5\": \"v5\",\n"
" \"k6\": \"v6\"\n"
"},\n"
"\"g3\": {\n"
" \"k7\": \"v7\",\n"
" \"k8\": \"v8\",\n"
" \"k9\": \"v9\"\n"
"},\n"
"\"g1\": {\n"
" \"k1\": \"v1\",\n"
" \"k2\": \"v2\",\n"
" \"k3\": \"v3\"\n"
"},\n"
"\"g2\": {\n"
" \"k4\": \"v4\",\n"
" \"k5\": \"v5\",\n"
" \"k6\": \"v6\"\n"
"},\n"
"\"g3\": {\n"
" \"k7\": \"v7\",\n"
" \"k8\": \"v8\",\n"
" \"k9\": \"v9\"\n"
"}")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)