const regex = new RegExp('\\s[-(/].*', 'gm')
const str = `One - two (three)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);