$re = '/stop(\w+| [^ ]+|$)/m';
$str = 'stop
stop random some company
stopping non stop
arif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);