re = /stop(\w+| [^ ]+|$)/m
str = 'stop
stop random some company
stopping non stop
arif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end