#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([pP][oO] +[bB][oO][xX]|[pP][rR][iI][vV][aA][tT][eE] +[bB][aA][gG]) +(\d+).*|^([\/\wÀ-ɏḀ-ỹ .'-]*, *)?(\d[\/\w]*)[\/\wÀ-ɏḀ-ỹ .,'#-]*$"
Local $sString = "Street address:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"224B Clarence Street, Vogeltown, Wellington 6023" & @CRLF & _
"" & @CRLF & _
"Rural address:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"128 Valley Road North, RD 2, Middlemarch 9597" & @CRLF & _
"" & @CRLF & _
"PO Box:" & @CRLF & _
"¯¯¯¯¯¯¯" & @CRLF & _
"PO Box 17999, Greenlane, Auckland 1546" & @CRLF & _
"" & @CRLF & _
"Street – with unit:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"3/123 Johnstone Street West, Point Chevalier, Auckland 1022" & @CRLF & _
"" & @CRLF & _
"Rural address with unit:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"8/56 Maple Boulevard, RD 2, Wanaka 9382" & @CRLF & _
"" & @CRLF & _
"Private Bag:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"Private Bag 93899, Auckland 0753" & @CRLF & _
"" & @CRLF & _
"Street – with building name:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"Level 2 Colombo House, 3A/1222 Colombo Street, St Albans, Christchurch 8014" & @CRLF & _
"" & @CRLF & _
"Rural address – with building name:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"Totârä Farm, 2/12543 Farm Road, RD 1, Outram 9073" & @CRLF & _
"" & @CRLF & _
"Rural address – with c/o:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"c/o James Bond, 2/12543 Farm Road, RD 1, Outram 9073" & @CRLF & _
"" & @CRLF & _
"Other addresses around the world:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"813 Howard Street, Oswego, NY 13126, USA" & @CRLF & _
"1 Beacon Street, 33rd Floor, Boston, MA 02108, USA" & @CRLF & _
"Hagagatan 1 vi, SE-113 49 Stockholm, Sweden" & @CRLF & _
"John A. Smith, ACME Innovations Inc., PO BOX 1033, Los Angeles, CA" & @CRLF & _
"c/o Henry Roth, 50 Oakland Ave,#206, A City, Florida, 32104, USA" & @CRLF & _
"10 Downing Street, London, Greater London, SW1A 2AA, United Kingdom" & @CRLF & _
"Av. de Senalèche 27, 1009 Pully, Switzerland" & @CRLF & _
"17, Rue Bergère, 75009 Paris, France" & @CRLF & _
"11 Bis Av. Gabriel Péri, 38150 Roussillon, France" & @CRLF & _
"Apostel-Paulus-Strasse 7, 10823 Berlin, Deutschland" & @CRLF & _
"Château Brillant, 75000 Paris, France" & @CRLF & _
"" & @CRLF & _
"Crap data:" & @CRLF & _
"¯¯¯¯¯¯¯¯¯¯" & @CRLF & _
"$^srflkwjeras %" & @CRLF & _
"894" & @CRLF & _
"879D" & @CRLF & _
"7895/465" & @CRLF & _
"5465 D" & @CRLF & _
"4565 D$ wer" & @CRLF & _
"House name, 45" & @CRLF & _
"Help me please!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")