import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(HORIZON-\\S+-[A-Z]\\d-\\d{2}\\S*)(?:\\r?\\n(?!Opening\\b).*)*\\r?\\nOpening: (.+)\\r?\\nDeadline\\(s\\): (.+)";
final String string = "\n"
+ "HORIZON-CL5-2021-D1-01\n"
+ "Conditions for the Call\n"
+ "Indicative budget(s) \n"
+ "Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded\n"
+ " 2021 \n"
+ "Opening: 15 Apr 2021\n"
+ "Deadline(s): 07 Sep 2021\n\n"
+ "HORIZON-CL5-2022-D1-01-two-stage\n"
+ "Conditions for the Call\n"
+ "Indicative budget(s) \n"
+ "Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded\n"
+ " 2022 \n"
+ "Opening: 04 Nov 2021\n"
+ "Deadline(s): 15 Feb 2022 (First Stage), 07 Sep 2022 (Second Stage)\n\n\n"
+ "HORIZON-CL5-2021-D2-01\n"
+ "Conditions for the Call\n"
+ "Indicative budget(s) \n"
+ "Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded\n"
+ " 2021 2022 \n"
+ "Opening: 15 Apr 2021\n"
+ "Deadline(s): 19 Oct 2021";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}