# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(HORIZON-\S+-[A-Z]\d-\d{2}\S*)(?:\r?\n(?!Opening\b).*)*\r?\nOpening: (.+)\r?\nDeadline\(s\): (.+)"
test_str = ("\n"
"HORIZON-CL5-2021-D1-01\n"
"Conditions for the Call\n"
"Indicative budget(s) \n"
"Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded\n"
" 2021 \n"
"Opening: 15 Apr 2021\n"
"Deadline(s): 07 Sep 2021\n\n"
"HORIZON-CL5-2022-D1-01-two-stage\n"
"Conditions for the Call\n"
"Indicative budget(s) \n"
"Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded\n"
" 2022 \n"
"Opening: 04 Nov 2021\n"
"Deadline(s): 15 Feb 2022 (First Stage), 07 Sep 2022 (Second Stage)\n\n\n"
"HORIZON-CL5-2021-D2-01\n"
"Conditions for the Call\n"
"Indicative budget(s) \n"
"Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded\n"
" 2021 2022 \n"
"Opening: 15 Apr 2021\n"
"Deadline(s): 19 Oct 2021")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.