#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:\[\d+])?(?:\.\w+(?:\[\d+])?)*$"
Local $sString = "parent[0].child" & @CRLF & _
"parent.child" & @CRLF & _
"parent.child1.list[0].child2" & @CRLF & _
"parent[500].child" & @CRLF & _
"parent0.child" & @CRLF & _
"par50ent.child" & @CRLF & _
"parent[0].child1[20].child[0]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"parent..child" & @CRLF & _
"parent[].child" & @CRLF & _
"parent[1a].child" & @CRLF & _
"parent[a].child" & @CRLF & _
".parent" & @CRLF & _
"parent."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")