re = /^\w+(?:\[\d+])?(?:\.\w+(?:\[\d+])?)*$/m
str = 'parent[0].child
parent.child
parent.child1.list[0].child2
parent[500].child
parent0.child
par50ent.child
parent[0].child1[20].child[0]
parent..child
parent[].child
parent[1a].child
parent[a].child
.parent
parent.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end