package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+\d{2})?[-. ]?[0-9]{3}?[-. ]?([0-9]{3})[-. ]?([0-9]{4})`)
var str = `1234567890
123-456-7890
123.456.7890
+44 123 456 7890
+30 210 111 1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}