$re = '/(\+\d{2})?[-. ]?[0-9]{3}?[-. ]?([0-9]{3})[-. ]?([0-9]{4})/m';
$str = '1234567890
123-456-7890
123.456.7890
+44 123 456 7890
+30 210 111 1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);