const regex = /(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.++)
)
(?!.{7}).(*SKIP).(?=(?:....(?&LINE){3,}|..|.(?&LINE)|(?&LINE){2})(?&LINE)(?&END))
|(?<=\n)(*SKIP)..(?=.++(?&LINE){3}(?&END))
|(?<=\n.)(*SKIP)..(?=.++(?&LINE){2}(?&END))
|(?<=\n..)(*SKIP)..(?=.++(?&LINE)(?&END))
|(?<=\n...)(*SKIP)(?=.++(?&END)).+(?=...(?&END))
|(?:(?<=\n....)|(?<=^....))..(*SKIP)(?=.++(?&LINE){4,}(?&END))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<END>\\n?$|\\n\\n)
(?<LINE>\\n.++)
)
(?!.{7}).(*SKIP).(?=(?:....(?&LINE){3,}|..|.(?&LINE)|(?&LINE){2})(?&LINE)(?&END))
|(?<=\\n)(*SKIP)..(?=.++(?&LINE){3}(?&END))
|(?<=\\n.)(*SKIP)..(?=.++(?&LINE){2}(?&END))
|(?<=\\n..)(*SKIP)..(?=.++(?&LINE)(?&END))
|(?<=\\n...)(*SKIP)(?=.++(?&END)).+(?=...(?&END))
|(?:(?<=\\n....)|(?<=^....))..(*SKIP)(?=.++(?&LINE){4,}(?&END))', 'g')
const str = `aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}