import Foundation
let pattern = #"""
(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.++)
)
(?!.{7}).(*SKIP).(?=(?:....(?&LINE){3,}|..|.(?&LINE)|(?&LINE){2})(?&LINE)(?&END))
|(?<=\n)(*SKIP)..(?=.++(?&LINE){3}(?&END))
|(?<=\n.)(*SKIP)..(?=.++(?&LINE){2}(?&END))
|(?<=\n..)(*SKIP)..(?=.++(?&LINE)(?&END))
|(?<=\n...)(*SKIP)(?=.++(?&END)).+(?=...(?&END))
|(?:(?<=\n....)|(?<=^....))..(*SKIP)(?=.++(?&LINE){4,}(?&END))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)