$re = '/^[A-Z, ]+?:$/mi';
$str = 'Smith, John, C:
test test
jsmith:
test test
test
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);