re = /^[A-Z, ]+?:$/mi
str = 'Smith, John, C:
test test
jsmith:
test test
test
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end