re = /\/\/.*/
str = '10 println "Testing Comment" //Test Comment
20 // THIS IS A COMMENT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end