use strict;
my $str = 'A = \'THIS IS AN ALPHABETIC /* CONSTANT\' || WS_CON1 /* */ || \'TEST STRING */\';';
my $regex = qr/([A-Z])\s(\/\*)\s([A-Z])/mp;
my $subst = '\\1 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";