$re = '/([A-Z])\s(\/\*)\s([A-Z])/m';
$str = 'A = \'THIS IS AN ALPHABETIC /* CONSTANT\' || WS_CON1 /* */ || \'TEST STRING */\';';
$subst = "\1 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;