#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^foo(?!.* ([abc]).*\1)(?: [abc])+$"
Local $sString = "foo a b c" & @CRLF & _
"foo b c a" & @CRLF & _
"foo a b" & @CRLF & _
"foo b" & @CRLF & _
"foo a b a" & @CRLF & _
"" & @CRLF & _
"foo b b" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")