re = /^foo(?!.* ([abc]).*\1)(?: [abc])+$/m
str = 'foo a b c
foo b c a
foo a b
foo b
foo a b a
foo b b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end